phpBB Mixed Content Fixer
phpBB

Mixed Content Fixer

Give your users complete security. For good.

Learn more

What is the problem?

You switched your board to secure HTTPS protocol, but your users post images from HTTP sources. That poses a threat to them, because an attacker can replace the image with his own content or use users' data against them.

Read more
Problem - mixed content warning
Solution - HTTP image proxy

How to fix this?

You as a domain owner should ensure that all content comes from secure origins. But this is difficult with forums, where users create the content. Luckily, there is a technique called HTTP proxy which solves the issue.

Final solution for forums

This extension utilizes such a HTTP proxy, replacing insecure images with a special link leading to your own server which downloads and secures the image instead of user's browser. Whatever your users post, you make them safe all the time.

Desired state - secure content information
Solution - HTTP image proxy

Any style, any language

The extension works under the hood - you and your users won't notice anything, regardless of board style and language. Neat, isn't it?

Lazyloading?

Using LazyLoad for post images extension? Don't worry, you are covered. Another extension that isn't supported? Just contact author.

Desired state - secure content information

Need hands-on first?

Sure, demo is available:

Launch demo

Pricing

Buy once, enjoy updates forever*.

4.99€
forever

Better secure than sorry.

  • 1 site license
  • Installation support
Buy a license

* Applies to current minor phpBB version, currently 3.2.x. Make sure to check license details before purchase.

Questions before purchase?

Don't hesitate to drop me a message.

Contact author